Bienvenue sur le site des Questions/Réponses du site www.mon-club-elec.fr. Posez vos questions autour de l'Arduino, de l'électronique programmée, de la programmation des mini-PC avec Pyduino ou encore du langage Python : nos spécialistes et la communauté vous répondront en français ! Notez les meilleures réponses : tous en profiteront !
Bienvenue sur le site des Questions/Réponses du site www.mon-club-elec.fr. Posez vos questions autour de l'Arduino, de l'électronique programmée, de la programmation des mini-PC avec Pyduino ou encore du langage Python : nos spécialistes et la communauté vous répondront en français ! Notez les meilleures réponses : tous en profiteront !

Message erreur apres un update

0 votes
Bonjour,
Voici le message qui apparait lorsque je lance un programme qui est cense faire clignoter une Led:
 
Pyduino for pcDuino - v0.4 - by www.mon-club-elec.fr - 2013 
PCDUINO
Traceback (most recent call last):
  File "/home/ubuntu/02_LED_on_off_IT_millis.py", line 37, in <module>
    setup() # appelle la fonction setup
  File "/home/ubuntu/02_LED_on_off_IT_millis.py", line 17, in setup
    pinMode(LED,OUTPUT) # met la broche en sortie
  File "/usr/lib/python2.7/dist-packages/pyduino/pyduino_hardware_pcduino.py", line 105, in pinMode
    file=open(pathMode+"gpio"+str(pin),'w') # ouvre le fichier en ecriture
IOError: [Errno 2] No such file or directory: '/sys/devices/virtual/misc/gpio/mode/gpio10'
 
Tout d'abord flicitation pour votre site.
J'ai achete un PCDuino V3 la semaine derniere et grace a vos explications j'ai pu le prendre en main.
Creation de programme avec IDE Pyduino, configuration de l'autostart du module, supervision avec VNC Viewer.... Un vrai bonheur.
Jusqu'a maintenant ou apres un update et un upgrade, le moindre programme qui utilise une entree sortie, plante..... 
Nul doute que vous puissiez m'aider. 
 
 
 
demandé 7-Jul-2014 dans PYDUINO : Broches E/S par brr69210 (230 points)

1 Réponse

+1 vote

La réponse à votre problème est probablement ici : http://www.services-mon-club-elec.fr/?qa=1/ou-est-pass%C3%A9-le-r%C3%A9pertoire-sys-devices-virtual-misc-gpio

à savoir :

A priori, ce sont les modules du noyau qui ne se chargent pas au lancement. Saisir les commandes dans un terminal :

sudo modprobe gpio
sudo modprobe adc
sudo modprobe pwm

si c'est ok, rendre les choses définitives avec :

sudo geany /etc/modules

ajouter les lignes :

gpio
adc
pwm

Enregistrer. Au démarrage suivant çà doit être bon.

 

 

répondu 7-Jul-2014 par xavadmin (3,140 points)
Shutdown impossible
...